Commit a58a65a5 authored by Aurélien Dunand's avatar Aurélien Dunand Committed by Seblu

Display minimum Installsystem version required when not satisfied

Signed-off-by: Seblu's avatarSébastien Luttringer <sebastien.luttringer@smartjog.com>
parent baa3c258
......@@ -638,7 +638,8 @@ class SourceImage(Image):
self.check_image_version(d["version"])
# check installsystems min version
if self.compare_versions(installsystems.version, d["is_min_version"]) < 0:
raise ISError("Minimum Installsystems version not satisfied")
raise ISError("Minimum Installsystems version not satisfied "
"(%s)" % d["is_min_version"])
except Exception as e:
raise ISError(u"Bad description", e)
return d
......@@ -798,7 +799,8 @@ class PackageImage(Image):
desc["is_min_version"] = 0
# check installsystems min version
if self.compare_versions(installsystems.version, desc["is_min_version"]) < 0:
raise ISError("Minimum Installsystems version not satisfied")
raise ISError("Minimum Installsystems version not satisfied "
"(%s)" % desc["is_min_version"])
except Exception as e:
raise ISError(u"Invalid description", e)
# try to load changelog
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment