Commit 8b11b051 authored by Seblu's avatar Seblu

Move base-seblu to a separate repository

parent 7f0faaae
# Maintainer: Sébastien Luttringer <seblu@archlinux.org>
pkgname=base-seblu
pkgver=2016.02.05
pkgrel=2
pkgdesc='Provide depends on minimal seblu hosts packages'
arch=('any')
url='https://github.com/seblu/arch-packages'
license=('GPL2')
install=$pkgname.install
package() {
depends=(
agetpkg
archutils-git
arptables
bash
bash-completion
bridge-utils
bzip2
colordiff
conntrack-tools
coreutils
cpupower
cryptsetup
device-mapper
diffutils
dmidecode
dnsutils
dstat
e2fsprogs
ebtables
ethtool
ferm
figlet
file
filesystem
fio
findutils
gawk
gcc-libs
gettext
git
glances
glibc
gptfdisk
grep
gzip
hddtemp
hdparm
hping
htop
iftop
inetutils
ioping
iotop
iperf
iproute2
ipset
iptraf-ng
iptstate
iputils
ipython
iw
kexec-tools
less
links
lm_sensors
logrotate
lrzsz
lshw
lsof
lsscsi
ltrace
lz4
man-db
man-pages
mdadm
moreutils
most
mtr
nano
ncdu
ndisc6
netperf
nfacct
nload
nmap
numactl
openssh
openvpn
pacman
pacman-contrib
parted
pciutils
pcmciautils
perl
perl-rename
procps-ng
psmisc
pv
python2
pwgen
reptyr
rsync
rxvt-unicode-terminfo
s-nail
screen
sdparm
sed
shadow
smartmontools
sshpass
strace
stress
sudo
sysfsutils
systemd-sysvcompat
tar
tcpdump
texinfo
traceroute
tree
unzip
usbutils
util-linux
vi-killer
vim
watchdog
wget
which
whois
xfsprogs
zip
zsh
zsh-completions
)
optdepends=(
'kernel-install-compat: compat helper for kernel-install'
'kernel-install-grub: grub helper for kernel-install'
)
conflicts=(
config-seblu
consolekit
initscripts
systemd-arch-units
sysvinit
tcp_wrappers
netcfg
netctl
)
install -dm755 "$pkgdir/usr/bin"
# perl-rename shortcut
ln -s perl-rename "$pkgdir/usr/bin/prename"
}
# vim:set ts=2 sw=2 et:
# vim:set ts=2 sw=2 et:
# arg 1: the new package version
post_install() {
# sbin should be a symlink
if [[ ! -L /usr/local/sbin ]]; then
rmdir '/usr/local/sbin' &&
ln -sn bin /usr/local/sbin &&
echo '!! /usr/local/sbin was not a symlink' ||
echo '!! /usr/local/sbin is not a symlink'
fi
# display depency info
echo '-- Unused dependencies:'
pacman -Qdt
echo '-- Local-only packages'
pacman -Qm
return 0
}
# arg 1: the new package version
# arg 2: the old package version
post_upgrade() {
post_install "$1"
}
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment