To find the state of this project's repository at the time of any of these versions, check out the tags.
changelog 8.81 KiB
installsystems (4) unstable; urgency=low
Aurélien Dunand (13):
Fix typos and docstring bad format
Fix missing parenthesises
add command takes several images files in one time
Remove unused import
help command can now displays subparsers' help
Reorder subparsers as the same order of their function
Add Unix globbing capability for repo_filter
Add search command
Cosmetics changes for list command
Add image retrieval from ftp
Copy file from http without read it in one time
Add copy command
Refactoring code for select one repository
Matthieu Gonnet (2):
Add clean command
Add check command
Seblu (66):
bump version
update release file
fix copy implementation.
fix use of non existant parameter keep
Add a move command
fix displaying of unknown command by help command
Remove update command
searching is now handled in repomananger
remplace pathtype == file by isfile
remove unneeded affectation
command add now take destination repository as parameter
fix type in new command help
repository can be unaivailable
Introducing a new way of selecting image
reorder alphabetically command name in is
allow version to be prefixed by v
Rewrite command cat
Command move use new style
better del asking implementation
Command copy use new image syntax
fix typo in tarball.py
command install use new image syntax
Remove select_one_repository. No more needed.
stricter check during image selection
list now use new syntax spec
reorder copy and move argument
temporary repo now have a unique identifier
repository on command line are added to the of repostiory in config file not supersede
Add extract command
Add command get
Smarter display during image loading
fix aurelien misunderstood epoch time
fix bug of data added in description.json
Fix unable to extract file from a remote directory
Fix extraction of tarball with non existant uid/gid
fix one lintian error from buildd message
fix aurelien misunderstood epoch time in repository
use istools.isfile instead of istools.pathtype == "file"
move repo filter inside repomanager
more precise message when image is not found
introduce offline repository mode
command list show offline status
reorder RepoManager and Repoconfig classes
fix again adunand gmttime issue
offline repository is no more used to get/search an image
Image download from repository is now handled by repository class
improve is help messages and options
fix missing gzip module in image.py
add a best mode to commands using image selection syntax
implement globbing on repository name in list
introduce color shortcut
introduce ask and confirm function
better error message when image file is invalid
improve tarball loading and check md5 from repository
list repo matching only on onlines repositories
set offline to false after creating a repository
add timeout to uopen
image name can use - and _
enforce image name and version checking
fix missing import sys in tarball
better display during repo cleaning
add a comment about python upstream bug
repo cleaning warn and not raise an error if it cannot delete a file
Print color only on a tty
Change clean command message
Add diff command
-- Sebastien Luttringer <sebastien.luttringer@smartjog.com> Thu, 01 Sep 2011 14:06:21 +0200
installsystems (3) unstable; urgency=low
Aurélien Dunand (7):
Add function to display packaged image content
Add function to display repository content
Add list command
Add cat command
Fix missing colon
cat command can display several files
Add update command
Seblu (17):
update release method
version 3~dev0
clean tar remove all tarball, not only current version
add version command
add help command
fix missing config files in debian package
fix typo
fix some python header
fix bad detection of destination file type during extraction
add emacs python header
change display of cat command
fix arrow spacing
change list behaviour
more spacing in list detail mode
check args boundary on command list
fix bad cache loading
more info before displaying content
-- Sebastien Luttringer <sebastien.luttringer@smartjog.com> Tue, 26 Jul 2011 12:28:49 +0200
installsystems (2) unstable; urgency=low
Aurélien Dunand (3):
Remove unused import
Fix typo in var name
Add human_size function
Seblu (24):
bump v2 devel
make clean remove tarball
installsystems package depends on same version of python-installsystems
Fix docstring bad format
Remove original file after adding to db
repoman is always used to handle repositories from is
Update argparse to python 2.7.2
add gzip to installsystems because python 2.6 doesn't have mtime optio
add isfile method
local repository are not cached by repomanager
init image and init repo splited in new and init command
remove exception in subcommand
init repository must not use load_repositories
Revert "Update argparse to python 2.7.2"
Python 2.7 is a minium requirement
setup install config files
make tar always recreate tarball
make deb doesn't sign package
fix debian dependancy to python2.7
Asking help with install display help including options from image
Fix extraction of broken tarball
Payloads are now created like --numeric-owner with tar
debian control needs an explicit python version
let make buildd distro be choose when calling make
-- Sebastien Luttringer <sebastien.luttringer@smartjog.com> Mon, 18 Jul 2011 13:01:31 +0200
installsystems (1) unstable; urgency=low
Aurélien Dunand (3):
Fix typos
Config filename must be a file
Missing parenthesises
Seblu (66):
Initial Commit
Add isimage binary and its module classes
Add isrepo and update common classes
Add isinstall and update common classes
isinstall update local cache only with -u
installsystems version is option -V not -v
isinstall can install local package
Introduce new module tools
Better detection of image name type
move md5sum into tools module
Fix bad deferencing in directory in /data of image
Generic improvment. Too many things to tell.
Fix stupid errors in tools module
Add tarfile from python 2.7
Fix repository deletion
Add config file
Add image data when running scripts
Remove pyxdg dependency
Allow chmod et chown, chgroup in repository config
Adding md5 of script tarball in repository
Improve remote cache. Http transport enabled
Add python 2.7 argparse in installsytems
Add timeout paramter to isinstall
Add configuration samples
isimage doesn't fail if image directory partially exists
Add required in default parser template
selecting of repo in isrepo is smarter
try..cactch in run scripts
Add extractdata method, which is an helper to extract content of tarball data
Compression is now gzip
script in tarball have now rights 755
Introduce RepositoryManager and extractdata
Donwloading image from repository verify md5
Add debian packaging
Change db format to sqlite3
Extract data compute name correctly
cleaning import
Introduce Payload
Keep global dict between parser and setup
arrow can be called without level and verbose
fix typo
script name must match the following regex \d+-.*\.py
Improve script execution
Improve arrow and printer
Fix downloading of all payloads to compute md5 when it's not needed
Adding script is now done one by one and not recursively
Check scripts syntax (by compiling) before adding
fix bad image file building
function name typo
New configuration style
Delete tarfile. We now don't use feature of last version
Add/Delete package in repository
handle db add in repo add
add message to explain which version is installe
Update makefile to easy publish
fix config file loading
Fix debian packaging
No more custom action to set debug and quiet mode
Merge command line tools into one
add a symlinks to is nammed installsystems
change installsytems default config file
Fix traceback cause to a debug message
fix config loading issue caused by argparse append
install command now use common loading repositories
Fix bad caching selection and disabling
Remove usage on error
-- Sebastien Luttringer <sebastien.luttringer@smartjog.com> Tue, 05 Jul 2011 18:04:07 +0200