-
Sebastien Luttringer authoredSebastien Luttringer authored
To find the state of this project's repository at the time of any of these versions, check out the tags.
changelog 15.12 KiB
installsystems (7) unstable; urgency=low
Sebastien Luttringer (1):
remove forgotten print
-- Sebastien Luttringer <sebastien.luttringer@smartjog.com> Fri, 23 Dec 2011 14:05:33 +0100
installsystems (6) unstable; urgency=low
Sebastien Luttringer (65):
return code is != 0 on error or keyboard interrupt
check command fail if cwd is not the repository path
replace double by simple quote in bash_completion
also mount /dev/shm inside chroot
chroot preparation doesn't mount on a mountpoint
error already exit with an error code
We don't need to ship argparse
Fix gzip payload failure on python 2.6
check repository name validity
add command repo
clean command options
new is list command
introduce list --no-sync option
add new command prepare_chroot and unprepare_chroot
prepare and unprepare chroot create resolf.conf only if /etc exists
prepare and unprepare enhancement
introduce ~ and + in installsystems versions
list command display md5 in line
add version field to repository
build now create payload without version
reorder option alphabeticall
add option -p to build
better error message in build comman
add a local state to repositories
new display and option for command repo
create a function to list all images in repoman
charachers avec [~-+] in version can be more than ascii
fix bug of color substituion
list only last version of one image by repo by default
install use a subparser for install scripts
Image are not searched in search path
add maintainers file
add -S, --search option to list command
add sphinx documentation
move display functions in binary
We need a recent version of python-argparse
fix missing parameter in arrow function
add --purge to command repo
add istrick file in {,un}prepare_chroot functions
reorder options
add is_version in tools
remove one check of image and payloads when adding to repo
fix repoman get return repo name on not repo object
fix displaying color with --no-color
fix typos
reindent bash completion with spaces
cat command display a warning if no file is selected by pattern
doesn't display directory with cat command
only use functions inside IS binary
add completion for {,un}prepare_chroot and -s
introduce repo and database strict versionning
add,check,clean,copy,init,move completion limit to local repositories
build command correclty handle ctrl+c and kill -15
list search on name if no / is present in pattern
repository name checking moved inside reposiory class
rename split_repositories into split_repository_list
list filter by search path if set
move --no-sync as program optio
cachify doesn't create empty file when failing to get database
remove --force-offline repo option
rewrite argument and config options loading
let argparse display version message
replace quiet and debug by verbosity
move python-progressbar from installsystems
image and database format use now x.y format
-- Sebastien Luttringer <sebastien.luttringer@smartjog.com> Fri, 23 Dec 2011 11:36:29 +0100
installsystems (5) unstable; urgency=low
Matthieu Gonnet (2):
is extract -D generate a description file from the description.json file
Fix typo
Sebastien Luttringer (61):
Introduce PipeFile in place of uopen
fix database init
Implement ssh transport
Repository add now user PipeFile
Add isversion inside images
Display progress bar during image creatio
use PipeFile.consume() in place of shutil.copyfileobj
Add changelog to images
Introduce changelog
Fix invalid payload namming during download
Offline state is now settable in repository.conf
Paramiko is not a hard dependency.
Rollback to python 2.6
Doesn't display warning when we are not in debug mode
fix missing progressbar package inside setup.py
Fix issue with utf8 encoding in author
fix extracting payload with utf8 filenames
fix is new traceback
allow format,description.json,changelog to be writable by user
is list display changelog only with -c or -v option
is new doesn't overwrite by default
Add command changelog
fix repo.show doesn't have changelog parameter
is list can display repository content with full path
add --no-color option to is
fix loading of parameters from config files
Reintroduce commit 184b64a23084a75513d48d336470f8048dd68b60
repository check now display corrupted files
add a minimal installsystems version option
rename isversion into is_build_version
image show display is_min_version in verbose mode
doesn't display changelog in list if no -c args in verbose mode
fix bad is_min_version syntax
fix changelog display which leads to a traceback
fix temporary caching of command line repostories
fix typo in compare_versio
add chroot command
add command info
fix typo
remove double definition of last in repository
fix presence of is_min_version during read_metadata
Add bash-completion
add long --all-version to -v in changelog
no progressbar in quiet mode
fix regex and is call in bash-completion
build command check and add script in alpha order
is get can now download only payloads
script without execution bit are not added in image
fix bash completion with positional argument and options
Allow del command to keep payload inside repository
use filepath and not filename in error in check_script
install bash comp list file after image
split tools' chroot in 3 functions
debian chroot hellper policy-rd needs to be executable
add resolv.conf copying in prepare chroot tricks
policy-rc.d must exit 101 in chroot
Add a download size information on download progressbar
fix error when chrooting inside a root without /etc
improve human_size computation
display time in rfc2822 format
remove image.id and use image.filename instead
-- Sebastien Luttringer <sebastien.luttringer@smartjog.com> Thu, 17 Nov 2011 12:56:57 +0100
installsystems (4) unstable; urgency=low
Aurélien Dunand (13):
Fix typos and docstring bad format
Fix missing parenthesises
add command takes several images files in one time
Remove unused import
help command can now displays subparsers' help
Reorder subparsers as the same order of their function
Add Unix globbing capability for repo_filter
Add search command
Cosmetics changes for list command
Add image retrieval from ftp
Copy file from http without read it in one time
Add copy command
Refactoring code for select one repository
Matthieu Gonnet (2):
Add clean command
Add check command
Seblu (66):
bump version
update release file
fix copy implementation.
fix use of non existant parameter keep
Add a move command
fix displaying of unknown command by help command
Remove update command
searching is now handled in repomananger
remplace pathtype == file by isfile
remove unneeded affectation
command add now take destination repository as parameter
fix type in new command help
repository can be unaivailable
Introducing a new way of selecting image
reorder alphabetically command name in is
allow version to be prefixed by v
Rewrite command cat
Command move use new style
better del asking implementation
Command copy use new image syntax
fix typo in tarball.py
command install use new image syntax
Remove select_one_repository. No more needed.
stricter check during image selection
list now use new syntax spec
reorder copy and move argument
temporary repo now have a unique identifier
repository on command line are added to the of repostiory in config file not supersede
Add extract command
Add command get
Smarter display during image loading
fix aurelien misunderstood epoch time
fix bug of data added in description.json
Fix unable to extract file from a remote directory
Fix extraction of tarball with non existant uid/gid
fix one lintian error from buildd message
fix aurelien misunderstood epoch time in repository
use istools.isfile instead of istools.pathtype == "file"
move repo filter inside repomanager
more precise message when image is not found
introduce offline repository mode
command list show offline status
reorder RepoManager and Repoconfig classes
fix again adunand gmttime issue
offline repository is no more used to get/search an image
Image download from repository is now handled by repository class
improve is help messages and options
fix missing gzip module in image.py
add a best mode to commands using image selection syntax
implement globbing on repository name in list
introduce color shortcut
introduce ask and confirm function
better error message when image file is invalid
improve tarball loading and check md5 from repository
list repo matching only on onlines repositories
set offline to false after creating a repository
add timeout to uopen
image name can use - and _
enforce image name and version checking
fix missing import sys in tarball
better display during repo cleaning
add a comment about python upstream bug
repo cleaning warn and not raise an error if it cannot delete a file
Print color only on a tty
Change clean command message
Add diff command
-- Sebastien Luttringer <sebastien.luttringer@smartjog.com> Thu, 01 Sep 2011 14:06:21 +0200
installsystems (3) unstable; urgency=low
Aurélien Dunand (7):
Add function to display packaged image content
Add function to display repository content
Add list command
Add cat command
Fix missing colon
cat command can display several files
Add update command
Seblu (17):
update release method
version 3~dev0
clean tar remove all tarball, not only current version
add version command
add help command
fix missing config files in debian package
fix typo
fix some python header
fix bad detection of destination file type during extraction
add emacs python header
change display of cat command
fix arrow spacing
change list behaviour
more spacing in list detail mode
check args boundary on command list
fix bad cache loading
more info before displaying content
-- Sebastien Luttringer <sebastien.luttringer@smartjog.com> Tue, 26 Jul 2011 12:28:49 +0200
installsystems (2) unstable; urgency=low
Aurélien Dunand (3):
Remove unused import
Fix typo in var name
Add human_size function
Seblu (24):
bump v2 devel
make clean remove tarball
installsystems package depends on same version of python-installsystems
Fix docstring bad format
Remove original file after adding to db
repoman is always used to handle repositories from is
Update argparse to python 2.7.2
add gzip to installsystems because python 2.6 doesn't have mtime optio
add isfile method
local repository are not cached by repomanager
init image and init repo splited in new and init command
remove exception in subcommand
init repository must not use load_repositories
Revert "Update argparse to python 2.7.2"
Python 2.7 is a minium requirement
setup install config files
make tar always recreate tarball
make deb doesn't sign package
fix debian dependancy to python2.7
Asking help with install display help including options from image
Fix extraction of broken tarball
Payloads are now created like --numeric-owner with tar
debian control needs an explicit python version
let make buildd distro be choose when calling make
-- Sebastien Luttringer <sebastien.luttringer@smartjog.com> Mon, 18 Jul 2011 13:01:31 +0200
installsystems (1) unstable; urgency=low
Aurélien Dunand (3):
Fix typos
Config filename must be a file
Missing parenthesises
Seblu (66):
Initial Commit
Add isimage binary and its module classes
Add isrepo and update common classes
Add isinstall and update common classes
isinstall update local cache only with -u
installsystems version is option -V not -v
isinstall can install local package
Introduce new module tools
Better detection of image name type
move md5sum into tools module
Fix bad deferencing in directory in /data of image
Generic improvment. Too many things to tell.
Fix stupid errors in tools module
Add tarfile from python 2.7
Fix repository deletion
Add config file
Add image data when running scripts
Remove pyxdg dependency
Allow chmod et chown, chgroup in repository config
Adding md5 of script tarball in repository
Improve remote cache. Http transport enabled
Add python 2.7 argparse in installsytems
Add timeout paramter to isinstall
Add configuration samples
isimage doesn't fail if image directory partially exists
Add required in default parser template
selecting of repo in isrepo is smarter
try..cactch in run scripts
Add extractdata method, which is an helper to extract content of tarball data
Compression is now gzip
script in tarball have now rights 755
Introduce RepositoryManager and extractdata
Donwloading image from repository verify md5
Add debian packaging
Change db format to sqlite3
Extract data compute name correctly
cleaning import
Introduce Payload
Keep global dict between parser and setup
arrow can be called without level and verbose
fix typo
script name must match the following regex \d+-.*\.py
Improve script execution
Improve arrow and printer
Fix downloading of all payloads to compute md5 when it's not needed
Adding script is now done one by one and not recursively
Check scripts syntax (by compiling) before adding
fix bad image file building
function name typo
New configuration style
Delete tarfile. We now don't use feature of last version
Add/Delete package in repository
handle db add in repo add
add message to explain which version is installe
Update makefile to easy publish
fix config file loading
Fix debian packaging
No more custom action to set debug and quiet mode
Merge command line tools into one
add a symlinks to is nammed installsystems
change installsytems default config file
Fix traceback cause to a debug message
fix config loading issue caused by argparse append
install command now use common loading repositories
Fix bad caching selection and disabling
Remove usage on error
-- Sebastien Luttringer <sebastien.luttringer@smartjog.com> Tue, 05 Jul 2011 18:04:07 +0200